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100% Job Guarantee In IT

v/ Government Registered Training Institute

v/ Current Industry Syllabus

v/ Industry-Ready Prep Course With 100% Job Guarantee
v/ 100% Project Oriented Training From Basics
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V/ Individual Focused Training
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ABOUT US!

Payilagam, the Best Software Training
Institute In Chennai With 100%
Placement Guarantee, has been shaping
successful IT careers with over 13+
Years Of Experience. we provide real-
time, industry-focused training led by
Experienced Professionals from the IT
industry, ensuring you gain practical
skills that companies actually need. Our
courses include HTML, CSS,
JavaScript, React, Java, Python,
PostgreSQL, GitLab, And WordPress,
designed to make you job-ready from day
one. At payilagam, we don’t just teach,
we guide you step-by-step towards your
career with our 100% Job Guaranteed
Courses, helping you confidently step
into the it industry.
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PRP COURSE

HTML & CSS

 Introduction To HTML Syntax, Introduction To CSS

» Block-Level Vs Inline Elements

 Common Elements: <div>, <span>, <p>, <a>, <br>, <hr> & So On

» Flex Properties, Input Types, Nesting Elements Correctly

e Basic Selectors: Element, Class, ID

* Grouping And Combining Selectors, Attribute Selectors

» Combinators:Descendant, Child (>), Adjacent Sibling (+), Sibling (~)

* Global Attributes: Id, Class, Title, Style, Lang

 Ordered Lists: <OIl>, <Li>, Unordered Lists: <Ul>, <Li>

* Description Lists: <DI>, <Dt>, <Dd>

» Data Specific Attributes: href, src, alt, type, value, placeholder
* Boolean Attributes: checked, disabled, readonly, required

» <form> Element And Its Attributes (action, method, etc.)
 Input Fields: <input>, <textarea>, <select>, <option>, <button>
» Fieldsets, Legends, And Labels

* Form Validation (required, pattern, minlength, maxlength)

» Understanding Content, Padding, Border, And Margin

» Using Box-Sizing: Border-Box

 Visualizing Box Dimensions With Dev Tools, Margin Collapsing

* Creating Tables With <Table>, <Tr>, <Th>, <Td>
» Table Structure: <Thead>, <Tbody>, <Tfoot>

* Merging Cells With Colspan And Rowspan

» Table Accessibility And Semantics

* Nesting And Styling Lists

 Block, Inline, Inline-Block, None, Flex, Grid

» Visibility: Hidden Vs Display: None
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PRP COURSE

HTML & CSS

* Introduction To Grid Layout

* Creating Columns And Rows Using Grid-Template-Columns And
Grid-Template-Rows

 Placing Items With Grid-Column, Grid-Row

e Grid Gap, Alignment, And Nested Grids

 Static, Relative, Absolute, Fixed, Sticky

» Using Top, Right, Bottom, Left With Positioning
» Z-Index And Stacking Context

* Media Queries For Responsive Designs

» Images: <img>, srcset, alt, picture

* Video: <video>, controls, autoplay, loop, muted

* Audio: <audio>, controls, autoplay, loop, preload
« Embedding YouTube And Other Media

 Grid, Navigation Bar, Display Properties

* Mouse Hover Functionalities

» Importance Of Semantic Elements For SEO & Accessibility

 Elements: <header>, <nav>, <main>, <section>, <article>, <aside>,
<footer>

* When And Where To Use Semantic Tags

* Creating A Nav Bar, Internal Linking Multiple HTML Pages, Border
Radius

¥ Assignments Will Be Given After Each Module***

@ www.payilagam.com @ +918344 777333 [< info@payilagam.com



PRP COURSE

JAVASCRIPT

» Understand Var, Let, And Const When And Why To Use Each
» Explore JavaScript's Powerful Dynamic Typing System
» Work With Strings, Numbers, Booleans, Null, Undefined, And More

» Arithmetic, Assignment, Comparison, And Logical Operators
» Master The Building Blocks Of Computation And Condition

 Decision-making with if, else, else if
* switch statement
* Ternary Operator
» Write clean, readable branching logic

» for, while, and dowhile Loops
» Introduction To forEach() For Working With Arrays

» Function Declarations

* Function Expressions

» Arrow Functions: Cleaner Syntax, Smarter Scopes

» Parameters, Return Values, And Function Composition
e (Call Back Function, Closure, Constructor Function

 Introduction To Object

* Nested Objects, Object Methods

* Create And Manipulate Object Literals

» Understand This In Different Contexts

» Work With Arrays: push, pop, shift, unshift, splice

» Use Powerful Array Methods: map(), filter(), reduce() for real-world
data tasks

@ www.payilagam.com @ +918344 777333 [< info@payilagam.com



PRP COURSE

JAVASCRIPT

* Selecting Elements: Use Document.GetElementByld, ClassName,
TagName, GetElementsByClassName, GetElementsByTagName,
QuerySelector & So On

 Change Text, Classes, Styles, Attributes, Creating New Elements,
Removing Existing Elements Dynamically

 Event Handling: OnClick(), OnMouseHover(), OnDoubleClick(),
Add Event Listeners, & So On

* Synchronous

» Asynchronous
 Callback And Callback Hell
e Promise

* Async/Await
» Application Programming Interface (Fetch and Axios API)

PROJECTS

* Variables, Data Types, Operators
 Interaction With HTML Elements Using DOM

 Inputs Types, Interaction With HTML Attributes Using DOM
» Event Handling (onClick())

» Learn Button And Positions, Interaction With CSS Using DOM
» Event Handling (mouseHover())

 Interaction With HTML Input Box Using DOM
» Event Handling (onInput(), onChange()), Using Arithmetic Operators
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PRP COURSE

JAVASCRIPT

» Introduction To Local Storage

 Storing And Retrieving Data

» Creating, Updating, And Deleting HTML Elements Dynamically
 Interaction With CSS (text-decoration)

* Functions

» (Conditional Statements, L.ooping

* (CSS Positioning

» Event Handling, Basic Animations

» Use Inbuilt Functions
* Creating Attractive Calculator Ul
» Operators, Conditional Statements, Mouse Hover Animations

» Conditional Statements, Form Attributes, Event Handling
 Interaction With CSS Using DOM
» Validating Inputs Using Conditional Statements

» Fetching Weather Data Using API
* Learn Asynchronous Functions
» Getting Data From JSON as Key And Value

» Using Array Methods: map, forEach
» Sending HTTP Requests

» Fetching Product Data Using API, Learn Asynchronous Functions

» Adding Features Like Add To Cart Button
* Looping Through Array Methods
» Event Handling (onClick(), onMouseHover())

¥k Assignments Will Be Given After Each Module™®**
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PRP COURSE

REACT JS

* What Is React? Why React?

 SPA Vs MPA

* Setup Using Vite Or Create React App
» JSX Syntax And Rules

» Functional Components

* Props And Component Reusability

* Conditional Rendering
» Lists And Keys

e useState, useEffect, useRef, useContext
 State Lifting
* Form Handling With Controlled Components

Projects: Counter Application, Password Hide/Show, Typing Speed
Check

 BrowserRouter, Routes, Route
 Link And NavLink

* Nested Routing
* Dynamic Routing With URL Params
» UseNavigate And Programmatic Routing

Projects: Multi Page Web App, Toggle Theme
 HTTP Methods And REST Principles
» Using Fetch And Axios, API Calls With UseEifect
» Handling Loading, Error, And Empty States
» Search And Filtering From API Data

Projects: Weather App, E-Commerce Web App
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PRP COURSE

JAVA

» Fundamentals Of OOP Concepts
» Benefits Of OOP Programming
* OOPs VS Other Programming Paradigms

« What Is Java?
 Features Of Java

» Advantages Of Java
 JDK, JVM, JRE Architecture

 Java Installation

» Eclipse IDE Installation
* My First Java Program
» Sample Java Program

» Java Tokens, Alphabets (Character Set)

* Primitive VS Non-Primitive Data Types

» Keywords, Java Reserved Keywords, Identifiers, Constants, Data
lypes, Operators.

* Control-Flow Statements

» Decision-Making Statements
o Switch, IF Else, Nested if

* Ternary Operators

* Break, Continue

* Looping Statements
e while, for, doWhile
* Break, Continue
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PRP COURSE

JAVA

* Method Calling From Main() Method

» Return Values From Called Method

» Significance Of Void, Return Keywords

» Argument Passing, L.ocal Variable, Global Variable
 Static, Non-Static Variables And Methods

» Introduction To Polymorphism
» Methods With Different No. And Type Of Arguments
* Method Overloading — Compile Time Polymorphism

» Create One More Class In Same Package— Class 2

» (Call Methods Present In Class 1 From Class 2
 Significance Of Access Modifiers — Private, Public And Default

* Create One More Class In Another Package — Class 2
» Try To Call Methods Present In Class 1 From Class 2

» Significance Of Access Moditier — Protected.

 Need For Inheritance
» [S-A Relationship

» Usage Of Extends Keyword
» Simple, Multilevel And Hierarchical Inheritance

* Create Child Class In Another Package— Class 2
» Significance Of Access Modifier — Protected.

e Method Overriding
* Type Casting
 super() And this() Keywords
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PRP COURSE

JAVA

* What Is Constructor

» How Constructor Is Being Called
» Rules For Constructor

* Constructor Overloading

* Scanner Class And Its Methods
» Converting All Their Previous Programs With Scanner Class

* Need For Array

» Types Of Arrays

* Array Declaration — Two Ways

» 2D, 3 Dimensional Arrays

 Int Array, Char Array, String Array

» Converting All Their Previous Programs With Scanner Class

 String Class

» String Declaration — Two Ways

 String Immutability Explanation

» Heap Memory, String Constant Pool Memory

» Difference Between String Literal And String Object

» Difference Between == Operator And Equals Method
» ToString() Method, HashCode() Method

* Details About Abstract Keyword

» Abstract Class

» Abstract Method

* Creating Object For Abstract Class Not Possible — Why
* Dynamic Binding / Late Binding

* Final Abstract Class Not Possible — How
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PRP COURSE

JAVA

 What Is Interface

e Difference Between Abstract Class And Interface
» Usage Of Implements Keyword

* Interface, Sub Interface

* Dynamic Binding / Late Binding

* What Is Exception

» Difference Between Exception And Error

» Syntax For Exception Handling Mechanism.

» Try Block, Catch Block, Exception , Checked Exceptions
» (Catch Block (Or) Multiple Catch.

» Throw, Throws, The Finally Block

» User Defined Exceptions.

* (Collection Framework

 (Collection Interfaces

» The List Interface And Its Implementation Classes

* The Set Interface And Its Implementation Classes

* The Queue Interface And Its Implementation Classes
» Map Interface And Its Implementation Classes

» ArrayList And Its Methods

» LinkedList And Its Methods

 Difference Between ArrayList And LinkedList
* Iterator Methods

» Getting Input From User And Sorting The ArrayList
* Searching In ArrayList
» Replacing Element In ArrayList
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PRP COURSE

JAVA

* Find Duplicate Character In A Given String Using HashMap
» Find Unique Characters In A Given String Using HashMap
* Find Count Of Characters In A Given String Using HashMap

* Need For Generics
» Simple Generics
» Sub Typing In Generics

* Predefined Packages
» User Defined Packages

» Threaded Application

 Thread States

 Runnable Interface And Thread Class

» Thread Priority

 Interrupting Threads (Sleep(), Join())

* Synchronization

e Intro. About Inter Thread Communication

e File Class
 How To Read A File — FileReader, BuftferedReader
 How To Write In A File — FileWriter, ButferedWriter

 What Is Functional Interface?
» Lambda Expression

¥ Assignments Will Be Given After Each Module™***
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PRP COURSE

POSTGRESQL

* What Is A Database? Types Of Databases

 RDBMS Vs NoSQL (With Examples)

* Why PostgreSQL?, Installing PostgreSQL And PgAdmin
 Introduction To PostgreSQL Ecosystem (CLI Tools, GUI, Drivers)

 Filtering With WHERE, AND, OR, IN, BETWEEN, LIKE
» Sorting Results: ORDER BY

* Limiting Data: LIMIT, OFFSET

e Aggregate Functions: COUNT, SUM, AVG, MIN, MAX

* Grouping Data: GROUP BY, HAVING

» Types Of Joins:
 INNER JOIN, LEFT JOIN, RIGHT JOIN, FULL OUTER JOIN
* Writing Nested Queries And Subqueries

» Using Subqueries In SELECT, WHERE, FROM
» Use Cases In Reporting And Data Analysis

* Creating And Using VIEWSs

» Materialized Views: Use Cases And Reireshing

* Creating Indexes: B-Tree

» Expression-Based Indexes

* Query Optimization Basics With EXPLAIN ANALYZE
 When And How Indexes Improve Performance

e Transactions: BEGIN, COMMIT, ROLLBACK
* Ensuring ACID Properties

» Save Points And Nested Transactions

» Handling Transaction Errors

» Use Cases: Banking Systems, Form Submissions
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PRP COURSE

POSTGRESQL

» Defining SQL & PL/PgSQL Functions
» Returning Values, Variables, And Conditional Logic
e Stored Procedures
* Iriggers:
 BEFORE And AFTER Triggers For INSERT, UPDATE,
DELETE

 Normalization:

* 1INF, 2NF, 3NF With Examples
» Entity Relationship Diagrams (ERD)
 Implementing:

* One-10-One

* One-To-Many

* Many-To-Many (Junction Tables)
 Using UUID As Primary Keys

» Creating Database Users And Roles
e Granting And Revoking Permissions:
 GRANT, REVOKE
» Role-Based Access Control (RBAC)
» Best Practices For Securing PostgreSQL In Production
* Schema-Level And Table-Level Permissions

¥ Assignments Will Be Given After Each Module***
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PRP COURSE

SPRING BOOT

 What Is A Server, Basic Client-Server Architecture?

» Understanding HTTP Methods.

* What Is Spring And Spring Boot?

* Learning The Architecture Diagram Of Spring MVC, Understanding
The Flow Of A Spring Boot.

* How To Build A Maven Project?, Maven Life Cycle.
* Building Jar And War, Difference Between Jar And War.

PROJECTS

» Understanding The Basic Annotations Used For Building A
Monolithic Enterprise Application.

* Creating Pojo, Using Lombok Dependency.

» Learn The Basics Of Thymeleat

» Connecting Controller To View In MVC Model
 Validation Of Incoming Request.

» Getting Inputs From Thymeleatf View
» Passing It To Controller , Learn The Basics Of Thymeleat
 Passing List Of String Objects To View

* Getting Inputs From View
 Passing Inputs To Controller
» Processing Inputs At Controller Side

» Adding Entity Class, Passing Model Values To Controller
» Transforming Objects To View From Controller
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PRP COURSE

SPRING BOOT

* Creating Quiz Application Using Thymeleaf / React And Springboot
And Publishing The Results

* Learning About HT'TP Session Maintenance
» Creating To Do List With Thymeleat / React
 Add To Do Item, Delete To Do Item

* Delete All To Do Items

 What Is REST API?, How To Access API Response?
» Accessing REST Results Through PostMan
* Open Weather Map API Integration, Getting Weather Details

* Swagger Ul, Open API

 Inbuilt Exception Handling In Spring Boot.
» Handling Default Exception And User Defined Exception.
* Presenting Proper Error Messages As Per The Exception Occurred.

» Usage Of Log4j, Adding Log4j In The Project
» Generation Of Log For All The Necessary Services

* What Is A Repository And Its Types?
» Difference Between CRUD And JPA Repository.

» User-Defined Query.
 Joining Tables And Do Operations On The Data.
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PRP COURSE

SPRING BOOT

» Usage Of JDBC Driver.
» Setting Path In Application.Properties File.

* How Spring Security Works.

» Explaining Spring Detault Authentication.

» Exploring Basic Auth Methods.

* Create Our Own Authentication Credentials.
 Creating Various Roles For Users.

» Authorization And Authentication As Per Roles

e Creating JSON

* Product List Page
* Add To Cart Page
e (Cart To Database
 Delete From Cart
* View Cart

» AI Chatbot Integration (React + Spring Boot)

» ChatGPT API Integration In Web Apps

» Al Text Generator (Blog / Product Description)
* Al-Based Search Feature (Smart Search)

» Al Recommendation System (Basic Logic)

* Al Form Assistance (Auto-Fill Suggestions)

» Al Resume Analyzer Web App Logic

* Al API Integration Using Spring Boot & React
» Handling AI Responses In Ul

» Prompt Writing For Developers

» Al Error Handling & API Limits

* Al Features In REST APIs

» Using Al With JSON Data
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PRP COURSE

SPRING BOOT

» AI Chatbot Web Application

* Al Resume Analyzer (Upload — Feedback)
» Al Blog Generator Website

» AI E-Commerce Recommendation System
» AI Customer Support Chat System

¥ Assignments Will Be Given After Each Module***
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PRP COURSE

NODE JS

Topics:
* What Is Node.Js — V8 Engine, Event Loop, Non-Blocking I/0
* Global Objects: Process, __dirname, __filename
e CommonJS Modules: Require() And Module.Exports
e ES Modules In Node: Import/Export Syntax
* Built-In Modules: Fs (ReadFile, WriteFile, AppendFile), Path, Os

» Npm Init, Package.Json, DevDependencies, Scripts, Nodemon

Class Activities:
* Run First Node.Js Script From Terminal
» Read/Write/Delete Files Using The Fs Module
* Build A Custom Helper Module/And Require It In Another File

Week Project:
* CLI Notes Manager-Add, List, Read, Delete Notes
» Stored As JSON Via Process.Argv Arguments

Topics:
* Creating An HTTP Server With The Built-In HTTP Module
* Reg And Res Objects - Routing Manually By URL And Method
» Serving HTML, JSON Responses; Status Codes & Headers
» EventEmitter Class - Emit() And On() Pattern
» Readable & Writable Streams; Piping Streams
» Dotenv Package - Environment Variables For Dev Vs Production

Class Activities:
* Build A Manual File Server Serving Static Assets
* Custom Event Logger Using EventkEmitter
» Stream A Large File To HT'TP Response Using Pipe
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PRP COURSE

NODE JS

Week Project:
* Projects 2 & 3: Static File Server
 HTML/CSS/Images, 404 Handling

» Event-Driven App Logger Writing Timestamped Logs To File

¥ Assignments Will Be Given After Each Module***
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PRP COURSE

EXPRESS JS

Topics:
 Installing Express, Project Folder Structure (MVC)
» App.Listen(); Res.Send(), Res.Json(), Res.Status()
» Route Parameters (Req.Params), Query Strings (Req.Query)
» Request Body Parsing: Req.Body With Express.Json()
» Express.Router() For Modular, Grouped Routes
» Middleware Chain: Custom, Morgan (Logging), Helmet (Security)
» Error-Handling Middleware: 4-Parameter Signature

Class Activities:
» Build A Basic Express Server And Test In Postman
* Create Modular Routes With Express.Router For Different Resources
* Add Morgan + Custom Request L.ogger Middleware

Week Project:
* API For Notes — Full CRUD
* (GET All, GET By ID, POST, PUT, DELETE)

» With In-Memory Array, Tested In Postman

Topics:
» Password Hashing With Bcrypt - SaltRounds, Hash, Compare
» JWT: Jsonwebtoken - Sign, Verity, Token Expiry
» Auth Middleware - Protect Routes With Token Verification
» HttpOnly Cookies With Cookie-Parser; CORS Configuration
» Rate Limiting With Express-Rate-Limit
e Multer For Multipart/Form-Data File Uploads; Express.Static()
 (Centralized Error Handler; Custom Error Classes; Consistent Error
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PRP COURSE

EXPRESS JS

Class Activities:
» Build Register/Login Endpoints With Bcrypt + JWT
 Add Auth Middleware To Protect A User Profile Route
» Upload Image File, Save To Disk, Return Public URL

Week Project:
» User Auth API + Blog API

» With Category Filtering & Pagination + Image
» Upload API With Multer

% Assignments Will Be Given After Each Module™®**
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PRP COURSE

MONGO DB

Topics:
* SQL Vs NoSQL — Key Ditferences; When To Use Each
* MongoDB Atlas Cloud Setup; MongoDB Compass GUI
 CRUD: InsertOne/Many, Find, FindOne
» UpdateOne/Many, DeleteOne/Many, Upsert
e Query Operators: $Eqg, $Gt, $Lt, $In, $Nin, $And, $Or, SRegex
» Mongoose: Connect, Schema Definition, Model Creation, Validation
* Model Methods: Save(), Find()
* FindByld(), FindByldAndUpdate(), FindByldAndDelete()

Class Activities:
» Set Up MongoDB Atlas Free Cluster And Connect Compass
* Run All CRUD Operations Directly In Compass
» Connect Mongoose To The Express API From Express JS Module

Week Project:
e Student Records API - Full

* Mongoose CRUD, Filter By Subject Or Grade
* Range Using Query Operators

Topics:
* Embedding Vs Referencing Documents - When To Use Each
» Populate() For Referenced Relationships Between Collections
* One-To-Many & Many-To-Many Schema Design Patterns
* Mongoose Virtual Fields, Timestamps (CreatedAt, UpdatedAt)
« Aggregation Pipeline: $Match, $Group, $Sort, $Limit, $Skip
« $L.ookup (Join Collections), $Unwind, $Project, $Count, $Sum
* Indexes: Single, Compound, Unique, TTL; Explain() For

Performance Analysis
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PRP COURSE

MONGO DB

Class Activities:
» Build Users + Posts Schema And Test Populate() In Postman
» Write An Aggregation To Get Total Orders Per Month
» Use Explain() To Compare Indexed Vs Non-Indexed Query
Performance

Week Project:
» Blog API With Populate
« E-Commerce Product Catalog With Search &
» Sort + Analytics Dashboard With Aggregation

¥ Assignments Will Be Given After Each Module™***
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PRP COURSE

INTEGRATION WEEK

Topics:
» Connect React Frontend To Express Backend With Axios
» Axios Base URL Configuration And Request Interceptors
e CORS Setup For Development And Production Environments
 JWT Auth Flow End-To-End
* React Form F1 Express F1 MongoDB F1 JW'T Fi1 React State
» Environment Variables In React (.Env With Vite) And Node
* Protected React Routes Using Stored JWT Token
» File Upload: React Form Fi Multer
* Fi Store Path In MongoDB Fi Return URL To React

Class Activities:
» Wire Up React App To Live REST API Endpoints
» Build Complete Login Flow Across All Three Layers
* Upload Image From React Component And Display In Ul

Week Project:
 Integration Project: Full Stack App With Auth,
 CRUD, And Image Upload - All Four Layers
» Connected And Working Together

Topics:
* Plan Schema Design And API Routes Before Writing Code
» Feature Scoping What Is Achievable In One Week
» Deploy Frontend To Vercel Or Netlify With Build Settings
* Deploy Backend To Render Or Railway (Free Tier)
» Connect MongoDB Atlas In Production Via Environment Variables
* GitHub Actions CI/CD: Auto-Deploy On Push To Main
 Portfolio Prep: README, Live URL, Clean Code, Demo Video
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PRP COURSE

INTEGRATION WEEK

Class Activities:
» Students Pitch Their Capstone Project Idea (Day 1)

» Daily Stand-Ups And Mid-Week Code Review Sessions
* Final Demo Day - Live Presentation To Class

Week Project:

» (Capstone Project: Student-Choice Full
 MERN App (E-Commerce, Job Board, Chat
* App, Or Project Manager): Deployed With Live URL
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PRP COURSE

PYTHON

» Python Introduction

* Download Python, Installing Python
 Verity The Installation

 Install A Text Editor Or IDE (Optional)

* Numeric Types
¢ lext lype

e Boolean Type
* None lype

» Arithmetic Operators

* Comparison Operators
* Logical Operators

* Assignment Operators
* Membership Operators
 Identity Operators

» Function Call

* Return Statement

» Types Of Parameters - Default Parameters, Variable Length
Arguments

* Variable-Length Argument Lists, Lambda Functions, Recursion

 Looping Statements: for, while

e Conditonal Statements: if, elif, else
 Exception Handling: try, except, finally
* Pass Statement

Project: Calculator Application
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PRP COURSE

PYTHON

* Creating A List

» Accessing Elements

» Slicing

* Modifying Elements

* Adding Elements

 Removing Elements

» Sorting: Bubble Sort, Searching: Binary Search

Project: Phone Book Application

* Creating A Tuple

» Accessing Elements

» Slicing

» Tuple Packing And Unpacking
e Immutable Nature

Project: Inventory Management Application
* Creating A Set
» Accessing Elements, Adding Elements, Removing Elements
* Set Operations
* Other Set Operations

Project: Unique Words From A Book
* Creating A Dictionary, Accessing Values, Modifying Values
» Adding New Key-Value Pairs, Removing Key-Value Pairs

 Dictionary Operations, Nested Dictionaries

Project: Student Management System
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PRP COURSE

PYTHON

* Creating A Package

» Importing Modules From A Package
» Importing The Whole Package

» Subpackages

¥ * Assignments Will Be Given After Each Module***

NOTE: EITHER NODE JS WITH EXPRESS JS OR JAVA WITH
SPRING BOOT WILL BE TEACHED BASED ON THE JOB
MARKET TREND
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PRP COURSE

MANUAL TESTING

» What Is Software Testing?, Why Testing Is Important?
» SDLC (Software Development Life Cycle)

» STLC (Software Testing Life Cycle)

 Verification Vs Validation, QA Vs QC Vs Testing

e Manual Testing Vs Automation Testing
» Black Box Testing

* White Box Testing

* Gray Box Testing,

* Functional Testing

* Non-Functional Testing

* Test Scenario Vs Test Case

* Boundary Value Analysis, Equivalence Partitioning, Decision Table
lesting

* State Iransition Testing

» Test Plan, Test Strategy, Test Case Writing, Test Execution Report
» Traceability Matrix (RTM)

* What Is Agile?

e Scrum Framework

* Roles (Scrum Master, Product Owner, Team)
» Sprint Planning & Daily Standup

* End-To-End Testing Project
* Test Case Writing, Bug Reporting
* Test Execution
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PRP COURSE

MANUAL TESTING

» Test Case Generation Using Al (Requirement — Test Cases)
* Bug Report Writing Using Al

* Test Scenario Creation Using Al

* Al For Test Data Generation

* Al For Regression Testing Support

» ChatGPT For Testing (Daily Work Usage)
* Al For API Testing Support

* Al For Writing Test Documentation

» Al For Exploratory Testing Ideas

» Al For Finding Edge Cases

* Prompt Writing For Testers

» Al Tools For QA (Basic Usage)

» Al For Faster Test Execution Planning

» Using Al In Agile Testing

* Al Test Case Generator Project

* Al Bug Report Assistant

* Al Test Scenario Generator

» Al-Based Test Documentation Project

» Al Testing Support For Web Application

¥k Assignments Will Be Given After Each Module***
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PRP COURSE

SEO & WORDPRESS

 SEO: On Page SEO, Off Page SEO, Technical SEO

 On Page SEO: Meta Data Optimization, Keyword Research,
Content Optimization, Image Optimization, Video Optimization,
Audio Optimization, Internal And External Linking, Content
Writing...

o Off Page SEO: Back Links Strategy, Guest Posting, Blog Writing.....

 Technical SEO: Sitemap, Robot.Txt, Site Crawling, Indexing,
Retrieving

* Screaming Frog SEO Spider

* Google Search Console

 GA4

» Extensions For Site Audit

* Google Keyword Planner

» WordPress For Site Development & SEO

 What Is Al, GenAl

Al Tools Overview: ChatGPT, Gemini & So On
» Al For Blog Writing

» Al Keyword Research Methods

» Competitor Analysis Using Al

» Content Gap Analysis
» Al-Based SEO Audits

¥k Assignments Will Be Given After Each Module™®**
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