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ABOUT US!

Payilagam, the Best Software Training
Institute In Chennai With 100%
Placement Guarantee, has been shaping
successful IT careers with over 13+
Years Of Experience. We provide real-
time, industry-focused training led by
Experienced Professionals from the IT
industry, ensuring you gain practical

skills that companies actually need. Our
COurses include HTML, CSS,

JavaScript, React, Java, Python, {H ;f
PostgreSQL, GitLab, And WordPress, *;E'%wﬁ“{;; |
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we guide you step-by-step towards your
career with our 100% Job Guaranteed
Courses, helping you confidently step
into the IT industry.
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FULL STACK JAVA

HTML & CSS

 Introduction To HTML Syntax, Introduction To CSS

» Block-Level Vs Inline Elements

 Common Elements: <div>, <span>, <p>, <a>, <br>, <hr> & So On

» Flex Properties, Input Types, Nesting Elements Correctly

e Basic Selectors: Element, Class, ID

* Grouping And Combining Selectors, Attribute Selectors

» Combinators:Descendant, Child (>), Adjacent Sibling (+), Sibling (~)

* Global Attributes: Id, Class, Title, Style, Lang

 Ordered Lists: <OIl>, <Li>, Unordered Lists: <Ul>, <Li>

* Description Lists: <DI>, <Dt>, <Dd>

» Data Specific Attributes: href, src, alt, type, value, placeholder
* Boolean Attributes: checked, disabled, readonly, required

» <form> Element And Its Attributes (action, method, etc.)
 Input Fields: <input>, <textarea>, <select>, <option>, <button>
 Fieldsets, Legends, And Labels

* Form Validation (required, pattern, minlength, maxlength)

» Understanding Content, Padding, Border, And Margin

» Using Box-Sizing: Border-Box

 Visualizing Box Dimensions With Dev Tools, Margin Collapsing

* Creating Tables With <Table>, <Tr>, <Th>, <Td>
» Table Structure: <Thead>, <Tbody>, <Tfoot>

* Merging Cells With Colspan And Rowspan

» Table Accessibility And Semantics

* Nesting And Styling Lists

 Block, Inline, Inline-Block, None, Flex, Grid

» Visibility: Hidden Vs Display: None
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FULL STACK JAVA

HTML & CSS

* Introduction To Grid Layout

* Creating Columns And Rows Using Grid-Template-Columns And
Grid-Template-Rows

 Placing Items With Grid-Column, Grid-Row

* Grid Gap, Alignment, And Nested Grids

» Static, Relative, Absolute, Fixed, Sticky

» Using Top, Right, Bottom, Left With Positioning
» Z-Index And Stacking Context

* Media Queries For Responsive Designs

* Images: <img>, srcset, alt, picture

* Video: <video>, controls, autoplay, loop, muted

* Audio: <audio>, controls, autoplay, loop, preload
* Embedding YouTube And Other Media

 Grid, Navigation Bar, Display Properties

* Mouse Hover Functionalities

» Importance Of Semantic Elements For SEO & Accessibility

 Elements: <header>, <nav>, <main>, <section>, <article>, <aside>,
<footer>

* When And Where To Use Semantic Tags

* Creating A Nav Bar, Internal Linking Multiple HTML Pages, Border
Radius

¥ Assignments Will Be Given After Each Module***
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FULL STACK JAVA

JAVASCRIPT

» Understand Var, Let, And Const When And Why To Use Each
» Explore JavaScript's Powerful Dynamic Typing System
» Work With Strings, Numbers, Booleans, Null, Undefined, And More

 Arithmetic, Assignment, Comparison, And Logical Operators
» Master The Building Blocks Of Computation And Condition

 Decision-making with if, else, else if
e switch statement
* Ternary Operator
» Write clean, readable branching logic

» for, while, and dowhile Loops
» Introduction To forEach() For Working With Arrays

* Function Declarations

* Function Expressions

» Arrow Functions: Cleaner Syntax, Smarter Scopes

» Parameters, Return Values, And Function Composition
e (Call Back Function, Closure, Constructor Function

 Introduction To Object

* Nested Objects, Object Methods

* Create And Manipulate Object Literals

» Understand This In Different Contexts

» Work With Arrays: push, pop, shift, unshift, splice

» Use Powerful Array Methods: map(), filter(), reduce() for real-world
data tasks
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FULL STACK JAVA

JAVASCRIPT

* Selecting Elements: Use Document.GetElementByld, ClassName,
TagName, GetElementsByClassName, GetElementsByTagName,
QuerySelector & So On

 Change Text, Classes, Styles, Attributes, Creating New Elements,
Removing Existing Elements Dynamically

 Event Handling: OnClick(), OnMouseHover(), OnDoubleClick(),
Add Event Listeners, & So On

* Synchronous

* Asynchronous
 Callback And Callback Hell
e Promise

* Async/Await
» Application Programming Interface (Fetch and Axios API)

PROJECTS

* Variables, Data Types, Operators
 Interaction With HTML Elements Using DOM

 Inputs Types, Interaction With HTML Attributes Using DOM
» Event Handling (onClick())

» Learn Button And Positions, Interaction With CSS Using DOM
» Event Handling (mouseHover())

 Interaction With HTML Input Box Using DOM
» Event Handling (onInput(), onChange()), Using Arithmetic Operators
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FULL STACK JAVA

JAVASCRIPT

» Introduction To Local Storage

 Storing And Retrieving Data

* Creating, Updating, And Deleting HITML Elements Dynamically
 Interaction With CSS (text-decoration)

* Functions

» Conditional Statements, L.ooping

* (CSS Positioning

» Event Handling, Basic Animations

» Use Inbuilt Functions
* Creating Attractive Calculator Ul
» Operators, Conditional Statements, Mouse Hover Animations

» (Conditional Statements, Form Attributes, Event Handling
» Interaction With CSS Using DOM
» Validating Inputs Using Conditional Statements

» Fetching Weather Data Using API
* Learn Asynchronous Functions
» Getting Data From JSON as Key And Value

» Using Array Methods: map, forEach
» Sending HTTP Requests

» Fetching Product Data Using API, Learn Asynchronous Functions

» Adding Features Like Add To Cart Button
» Looping Through Array Methods
» Event Handling (onClick(), onMouseHover())

% Assignments Will Be Given After Each Module™®**
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FULL STACK JAVA

REACT JS

* What Is React? Why React?

 SPA Vs MPA

* Setup Using Vite Or Create React App
» JSX Syntax And Rules

* Functional Components

» Props And Component Reusability

* Conditional Rendering
» Lists And Keys

e useState, useEffect, useRef, useContext
o State Lifting
* Form Handling With Controlled Components

Projects: Counter Application, Password Hide/Show, Typing Speed
Check

 BrowserRouter, Routes, Route
 Link And NavLink

* Nested Routing
* Dynamic Routing With URL Params
» UseNavigate And Programmatic Routing

Projects: Multi Page Web App, Toggle Theme
 HTTP Methods And REST Principles
» Using Fetch And Axios, API Calls With UseEifect
» Handling Loading, Error, And Empty States
» Search And Filtering From API Data

Projects: Weather App, E-Commerce Web App
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FULL STACK JAVA

REACT JS

» UseReducer For Complex State Management
» UseMemo And UseCallback For Optimization
e Custom Hooks

* Debouncing And Throttling With Hooks

Projects: Form Validation

» Understanding Prop Drilling

* Context API With Custom Hooks

» Redux Toolkit: Slices, Store, UseDispatch/UseSelector, Async Thunks
» React Query / TanStack Query (Bonus)

Projects: Quiz Application

* CSS Modules

» Tailwind CSS

» Styled-Components

* Responsive Design Strategies

» Component Reusability, React. Memo And Pure Components
» Lazy Loading And Code Splitting Using React

* Lazy And Suspense

 Error Boundaries, Folder Structure And Naming Conventions

» Building React Apps For Production

» Hosting On Netlify, Vercel, Or GitHub Pages
» Using Environment Variables (.Env)

» Introduction To CI/CD Using GitHub Actions
» Above Project Will Be Hosted Using Vercel
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FULL STACK JAVA

JAVA

* Fundamentals Of OOP Concepts
» Benefits Of OOP Programming
e OOPs VS Other Programming Paradigms

« What Is Java?
 Features Of Java

» Advantages Of Java
 JDK, JVM, JRE Architecture

 Java Installation

» Eclipse IDE Installation
* My First Java Program
e Sample Java Program

» Java Tokens, Alphabets (Character Set)

* Primitive VS Non-Primitive Data Types

» Keywords, Java Reserved Keywords, Identifiers, Constants, Data
lypes, Operators.

» Control-Flow Statements

» Decision-Making Statements
o Switch, IF Else, Nested if

* Ternary Operators

* Break, Continue

* Looping Statements
e while, for, doWhile
* Break, Continue
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FULL STACK JAVA

JAVA

* Method Calling From Main() Method

» Return Values From Called Method

» Significance Of Void, Return Keywords

» Argument Passing, L.ocal Variable, Global Variable
» Static, Non-Static Variables And Methods

* Introduction To Polymorphism
» Methods With Different No. And Type Of Arguments
* Method Overloading — Compile Time Polymorphism

» Create One More Class In Same Package— Class 2

» (Call Methods Present In Class 1 From Class 2
 Significance Of Access Modifiers — Private, Public And Default

* Create One More Class In Another Package — Class 2
» Try To Call Methods Present In Class 1 From Class 2

» Significance Of Access Moditier — Protected.

* Need For Inheritance
» [S-A Relationship

» Usage Of Extends Keyword
» Simple, Multilevel And Hierarchical Inheritance

* Create Child Class In Another Package— Class 2
» Significance Of Access Modifier — Protected.

» Method Overriding
* Type Casting
 super() And this() Keywords
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FULL STACK JAVA

JAVA

» What Is Constructor

» How Constructor Is Being Called
» Rules For Constructor

* Constructor Overloading

* Scanner Class And Its Methods
» Converting All Their Previous Programs With Scanner Class

* Need For Array

» Types Of Arrays

* Array Declaration — Two Ways

» 2D, 3 Dimensional Arrays

 Int Array, Char Array, String Array

» Converting All Their Previous Programs With Scanner Class

 String Class

» String Declaration — Two Ways

 String Immutability Explanation

» Heap Memory, String Constant Pool Memory

» Difference Between String Literal And String Object

» Difference Between == Operator And Equals Method
» ToString() Method, HashCode() Method

* Details About Abstract Keyword

» Abstract Class

» Abstract Method

* Creating Object For Abstract Class Not Possible — Why
» Dynamic Binding / Late Binding

* Final Abstract Class Not Possible — How
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FULL STACK JAVA

JAVA

 What Is Interface

e Difference Between Abstract Class And Interface
» Usage Of Implements Keyword

* Interface, Sub Interface

» Dynamic Binding / Late Binding

* What Is Exception

» Difference Between Exception And Error

» Syntax For Exception Handling Mechanism.

» Try Block, Catch Block, Exception , Checked Exceptions
» (Catch Block (Or) Multiple Catch.

» Throw, Throws, The Finally Block

» User Defined Exceptions.

* (Collection Framework

* (Collection Interfaces

» The List Interface And Its Implementation Classes

* The Set Interface And Its Implementation Classes

e The Queue Interface And Its Implementation Classes
» Map Interface And Its Implementation Classes

» ArrayList And Its Methods

» LinkedList And Its Methods

» Difference Between ArrayList And LinkedList
* Iterator Methods

» Getting Input From User And Sorting The ArrayList
» Searching In ArrayList
» Replacing Element In ArrayList
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FULL STACK JAVA

JAVA

* Find Duplicate Character In A Given String Using HashMap
» Find Unique Characters In A Given String Using HashMap
* Find Count Of Characters In A Given String Using HashMap

* Need For Generics
» Simple Generics
» Sub Typing In Generics

* Predefined Packages
» User Defined Packages

» Threaded Application

 Thread States

 Runnable Interface And Thread Class

» Thread Priority

 Interrupting Threads (Sleep(), Join())

* Synchronization

e Intro. About Inter Thread Communication

e File Class
 How To Read A File — FileReader, BuftferedReader
 How To Write In A File — FileWriter, ButferedWriter

 What Is Functional Interface?
» Lambda Expression

¥ Assignments Will Be Given After Each Module™***
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FULL STACK JAVA

POSTGRESQL

* What Is A Database? Types Of Databases

 RDBMS Vs NoSQL (With Examples)

* Why PostgreSQL?, Installing PostgreSQL And PgAdmin
 Introduction To PostgreSQL Ecosystem (CLI Tools, GUI, Drivers)

 Filtering With WHERE, AND, OR, IN, BETWEEN, LIKE
» Sorting Results: ORDER BY

* Limiting Data: LIMIT, OFFSET

e Aggregate Functions: COUNT, SUM, AVG, MIN, MAX

* Grouping Data: GROUP BY, HAVING

» Types Of Joins:
 INNER JOIN, LEFT JOIN, RIGHT JOIN, FULL OUTER JOIN
* Writing Nested Queries And Subqueries

» Using Subqueries In SELECT, WHERE, FROM
» Use Cases In Reporting And Data Analysis

* Creating And Using VIEWSs

» Materialized Views: Use Cases And Reireshing

* Creating Indexes: B-Tree

» Expression-Based Indexes

* Query Optimization Basics With EXPLAIN ANALYZE
 When And How Indexes Improve Performance

e Transactions: BEGIN, COMMIT, ROLLBACK
* Ensuring ACID Properties

» Save Points And Nested Transactions

» Handling Transaction Errors

» Use Cases: Banking Systems, Form Submissions
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FULL STACK JAVA

POSTGRESQL

» Defining SQL & PL/PgSQL Functions
» Returning Values, Variables, And Conditional Logic
e Stored Procedures
* Triggers:
 BEFORE And AFTER Triggers For INSERT, UPDATE,
DELETE

 Normalization:

* 1NF, 2NF, 3NF With Examples
» Entity Relationship Diagrams (ERD)
 Implementing:

* One-10-One

* One-To-Many

* Many-To-Many (Junction Tables)
 Using UUID As Primary Keys

» Creating Database Users And Roles
e Granting And Revoking Permissions:
 GRANT, REVOKE
» Role-Based Access Control (RBAC)
» Best Practices For Securing PostgreSQL In Production
* Schema-Level And Table-Level Permissions

¥ Assignments Will Be Given After Each Module***
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FULL STACK JAVA

SPRING BOOT

 What Is A Server, Basic Client-Server Architecture?

» Understanding HTTP Methods.

* What Is Spring And Spring Boot?

* Learning The Architecture Diagram Of Spring MVC, Understanding
The Flow Of A Spring Boot.

* How To Build A Maven Project?, Maven Life Cycle.
 Building Jar And War, Difference Between Jar And War.

PROJECTS

» Understanding The Basic Annotations Used For Building A
Monolithic Enterprise Application.

* Creating Pojo, Using Lombok Dependency.

» Learn The Basics Of Thymeleat

» Connecting Controller To View In MVC Model
 Validation Of Incoming Request.

» Getting Inputs From Thymeleatf View
» Passing It To Controller , Learn The Basics Of Thymeleat
 Passing List Of String Objects To View

* Getting Inputs From View
 Passing Inputs To Controller
» Processing Inputs At Controller Side

» Adding Entity Class, Passing Model Values To Controller
» Transforming Objects To View From Controller
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FULL STACK JAVA

SPRING BOOT

* Creating Quiz Application Using Thymeleaf / React And Springboot
And Publishing The Results

* Learning About HT'TP Session Maintenance
» Creating To Do List With Thymeleat / React
 Add To Do Item, Delete To Do Item

* Delete All To Do Items

 What Is REST API?, How To Access API Response?
» Accessing REST Results Through PostMan
* Open Weather Map API Integration, Getting Weather Details

* Swagger Ul, Open API

 Inbuilt Exception Handling In Spring Boot.
» Handling Default Exception And User Defined Exception.
* Presenting Proper Error Messages As Per The Exception Occurred.

» Usage Of Log4j, Adding Log4j In The Project
» Generation Of Log For All The Necessary Services

* What Is A Repository And Its Types?
» Difference Between CRUD And JPA Repository.

» User-Defined Query.
 Joining Tables And Do Operations On The Data.
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FULL STACK JAVA

SPRING BOOT

» Usage Of JDBC Driver.
» Setting Path In Application.Properties File.

* How Spring Security Works.

» Explaining Spring Detault Authentication.

» Exploring Basic Auth Methods.

* Create Our Own Authentication Credentials.
 Creating Various Roles For Users.

» Authorization And Authentication As Per Roles

e Creating JSON

* Product List Page
* Add To Cart Page
e (Cart To Database
 Delete From Cart
* View (Cart

» AI Chatbot Integration (React + Spring Boot)

» ChatGPT API Integration In Web Apps

» Al Text Generator (Blog / Product Description)
» Al-Based Search Feature (Smart Search)

» Al Recommendation System (Basic Logic)

* Al Form Assistance (Auto-Fill Suggestions)

* Al Resume Analyzer Web App Logic

* Al API Integration Using Spring Boot & React
» Handling AI Responses In Ul

* Prompt Writing For Developers

» Al Error Handling & API Limits

* Al Features In REST APIs

» Using Al With JSON Data
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FULL STACK JAVA

SPRING BOOT

» AI Chatbot Web Application

* Al Resume Analyzer (Upload — Feedback)
» Al Blog Generator Website

» AI E-Commerce Recommendation System
» AI Customer Support Chat System

¥ Assignments Will Be Given After Each Module***
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FULL STACK JAVA

PYTHON

» Python Introduction

» Download Python, Installing Python

» Verity The Installation

 Install A Text Editor Or IDE (Optional)

* Numeric Types
* lext lype

* Boolean Type
* None lype

» Arithmetic Operators

* Comparison Operators
* Logical Operators

* Assignment Operators
* Membership Operators
 Identity Operators

* Function Call

* Return Statement

» Types Of Parameters - Default Parameters, Variable Length
Arguments

* Variable-Length Argument Lists, Lambda Functions, Recursion

* Looping Statements: for, while

e Conditonal Statements: if, elif, else
 Exception Handling: try, except, finally
* Pass Statement

Project: Calculator Application
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FULL STACK JAVA

PYTHON

* Creating A List

» Accessing Elements

» Slicing

* Modifying Elements

* Adding Elements

 Removing Elements

» Sorting: Bubble Sort, Searching: Binary Search

Project: Phone Book Application

* Creating A Tuple

» Accessing Elements

» Slicing

» Tuple Packing And Unpacking
* Immutable Nature

Project: Inventory Management Application
* Creating A Set
» Accessing Elements, Adding Elements, Removing Elements
* Set Operations
* Other Set Operations

Project: Unique Words From A Book
» Creating A Dictionary, Accessing Values, Modifying Values
» Adding New Key-Value Pairs, Removing Key-Value Pairs

» Dictionary Operations, Nested Dictionaries

Project: Student Management System
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FULL STACK JAVA

PYTHON

* Creating A Package

» Importing Modules From A Package
» Importing The Whole Package

» Subpackages

» (Class, Object
 Attributes And Methods
» Encapsulation
 Inheritance

* Polymorphism

» Abstraction

Project: Employee Management System

 Instance Methods

» (Class Methods
 Static Methods
» Special Methods (Magic Methods Or Dunder Methods)

» Try-Except Block

» Handling Specific Exceptions

» Else And Finally Blocks

» Raising And Custom Exceptions

* Opening, Reading, Writing From A File, Appending To A File
» Using With Statements, File Modes
» Exception Handling For File Operations, Working With Paths

Project: CSV File Parser Application
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FULL STACK JAVA

PYTHON

» Basics Of Regular Expressions
» Using Regular Expressions In Python

Projects:
1. Email Validator

2. Mobile Number Extractor
3. Password Validator

* Creating Threads
» Thread Synchronization
 Thread Communication
 Daemon Threads

¥k Assignments Will Be Given After Each Module***
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